mirror of https://github.com/pyodide/pyodide.git
29 lines
804 B
Diff
29 lines
804 B
Diff
From 02a6efc43d2245947853b77e5417b11d671a2510 Mon Sep 17 00:00:00 2001
|
|
From: Jo Bovy <bovy@astro.utoronto.ca>
|
|
Date: Wed, 8 Jun 2022 15:43:04 -0400
|
|
Subject: [PATCH 1/2] Force GSL version to 2.7 for pyodide build
|
|
|
|
---
|
|
setup.py | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 8a7eaf1..b94620b 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -108,7 +108,10 @@ try:
|
|
subprocess.check_output(cmd,
|
|
shell=sys.platform.startswith('win'))
|
|
except (OSError,subprocess.CalledProcessError):
|
|
- gsl_version= ['0','0']
|
|
+ if "PYODIDE" in os.environ:
|
|
+ gsl_version= ['2','7']
|
|
+ else:
|
|
+ gsl_version= ['0','0']
|
|
else:
|
|
if PY3:
|
|
gsl_version= gsl_version.decode('utf-8')
|
|
--
|
|
2.32.1 (Apple Git-133)
|
|
|