mirror of https://github.com/pyodide/pyodide.git
18 lines
576 B
Diff
18 lines
576 B
Diff
arith.h is a file generated at build time by compiling and running a C program.
|
|
Since we use emscripten to build throughout, the C program becomes a wasm file
|
|
and we call it differently.
|
|
|
|
--- a/F2CLIBS/libf2c/Makefile
|
|
+++ b/F2CLIBS/libf2c/Makefile
|
|
@@ -184,8 +184,8 @@
|
|
arith.h: arithchk.c
|
|
$(CC) $(CFLAGS) -DNO_FPINIT arithchk.c -lm ||\
|
|
$(CC) -DNO_LONG_LONG $(CFLAGS) -DNO_FPINIT arithchk.c -lm
|
|
- ./a.out >arith.h
|
|
- rm -f a.out arithchk.o
|
|
+ node a.out.js >arith.h
|
|
+ rm -f a.out.js a.out.wasm
|
|
|
|
check:
|
|
xsum Notice README abort_.c arithchk.c backspac.c c_abs.c c_cos.c \
|